View my account

PCL cloud view is not correct if the frame read using syncer class & depth_sensor.on_video_frame APIs



  • MartyG

    Hi Lalatendu Das  There is a lot of information to digest here.  As you believe that the main symptom is incorrect RGB mapping, let's tackle that aspect first.

    I located another case where the RGB was incorrect in relation to the depth frame when using syncer.  The RealSense user in that case was advised to disable the Auto-Exposure Priority setting and ensure that both depth and color were set to the same FPS.

    When Auto-Exposure is enabled and Auto-Exposure Priority is disabled, it enforces a constant FPS speed.

    If you are using C++ language, the code in the link below shows how to disable Auto-Exposure Priority, taking care to ensure that the command is directed at the RGB sensor (index '1') instead of the depth sensor (index '0').

    Comment actions Permalink
  • Lalatendu Das

    Hi MartyG

    Thanks for your response. The Auto-Exposure Priority disable didn't help much. The issue finally got fixed by setting correct bits per pixel value for RGB frame (i.e. 3 instead of same as what mentioned for depth) and applying the correct intrinsic values to software device by reading it from camera object and not hardcoding it. So we can close this thread.

    Comment actions Permalink

Please sign in to leave a comment.