View my account

I have very large error in depth data when using d435

Comments

9 comments

  • MartyG

    Hi Sangngvt  Please provide depth and RGB images of the wall in a comment below, as this will help to identify whether there is something in the location that the camera is being used in that is potentially disruptive to the depth sensing.  Thanks!

    0
    Comment actions Permalink
  • Sangngvt

    Thank you for replying me, here are rgb and depth images:

     

    0
    Comment actions Permalink
  • Sangngvt

    0
    Comment actions Permalink
  • Sangngvt

    As you can see the depth here is 1.3m, however when i measured with a tape ruler, it was 0.59m

    0
    Comment actions Permalink
  • MartyG

    The wall has a rough textured surface, which is good for depth analysis.  So there should be no problem there.

     

    In the above image Emitter Enabled is set to off instead of Laser, so the camera will not be projecting an invisible pattern of dots onto the wall to aid depth analysis.  Having the emitter off can result in reduced depth image quality.  I note though that you have already tried with the emitter set to Laser.

     

    Despite the emitter being off in the above image, it is actually a good quality depth image.

     

    Because you quote a few different depth readings, it sounds as though the depth values are fluctuating.  To help to stabilize the depth values, you could go to the Post-Processing section of the options side panel and expand open the Temporal Filter settings, then change the Smooth Alpha setting from its default of '0.4' to a lower value of '0.1'.

     

    0
    Comment actions Permalink
  • Sangngvt

    hey, i tried changing the settings as you said and the error is still the same.

    0
    Comment actions Permalink
  • MartyG

    Is there any improvement if you change the Preset at the top of the options side-panel from 'Custom' to 'High Accuracy'.

     

    You can also try going to Stereo Module > Advanced Controls > Depth Control and change the topmost option 'DS Second Peak Threshold' from its default of '325' down to '0'.

    0
    Comment actions Permalink
  • Sangngvt

    Hey i found an old topic and i tried to reset the calibration data to its factory and the camera seem back to normal, thank you for your help

    0
    Comment actions Permalink
  • MartyG

    You are very welcome.  It's excellent to hear that you found a solution that works for you.  Thanks very much for the update!

    0
    Comment actions Permalink

Please sign in to leave a comment.