View my account

L515 Not working/Windows 10



  • Official comment
    Jesus Garcia

    Hello Akdba0207,

    I am sorry for this inconvenience. We will send you a private email in order to get some information about your L515 orders.

    Jesus G.
    Intel Customer Support

    Comment actions Permalink
  • Rahulthevaishnav

    Hi , 

    I received my L515 yesterday, I am having the same problem. Was it solved ?

    Comment actions Permalink
  • Jerry Gadd

    I have same problem too! my device doesnt get registered by the OS when i plug it in at all anymore.

    Comment actions Permalink
  • Manuel Korell

    Hi All.

    I have the same problem, L515 is not recognized in either Windows 10 or Ubuntu 18.04. Output with rs-fw-update -l is "there are no connected devices"
    My D435i works on the same cable if I change device. I use a USB3 port.
    When I use dmesg, the L515 does not appear either. The weird thing is, everything worked the day before.
    Now I do not know what I can do, because it seems like there is no communication at all.

    Comment actions Permalink
  • Aznie Syaarriehaah

    Hello Jerry​ ,


    We apologize for the inconvenience.


    The first thing to try is flipping the USB-C connector into the camera and inserting it the opposite way to change its polarity. If this doesn’t solve your issue, help us troubleshoot by telling us how the camera was handled before the problem occurred.


    The answers to these questions will not affect your warranty. We just want to know why these issues are happening.


    1. Did this happen on the first connection straight out of the box?
    2. How is the camera mounted?
    3. Are you using the tripod and cable that came with the package?
    4. Was the camera dropped?
    5. Was the camera banged against an object?
    6. Can you describe any physical impacts on the camera?


    Meanwhile, can you also tested your camera on another computer and see if it is detected or not.




    Intel RealSense Customer Support

    Comment actions Permalink

Please sign in to leave a comment.