View my account

Installing D400 UWP driver disables Infrared streams on D435

Comments

11 comments

  • Duppy Proctor

    Not only are the streams not available from Intel.RealSense.Viewer, also when I try to open the streams from code I get an error.

     

     

    0
    Comment actions Permalink
  • MartyG

    Hi Duppy Proctor  It is not necessary to install the RealSense UWP driver to add support for hardware metadata.  This can be done through the RealSense Viewer tool.

    The UWP driver is also not required to use RealSense cameras with Windows unless you need to interface the camera with a product that supports the Microsoft Universal Windows Platform (UWP), such as the HoloLens headset.

    I was able to confirm that installing the current version of the UWP driver (6.1.160.22) caused the Infrared channels to become inaccessible.  I have highlighted the issue to Intel to seek feedback.  Thanks very much for your patience.

    0
    Comment actions Permalink
  • MartyG

    Hi again.  I consulted with Intel and received a solution that I was able to test as successful on two separate Windows PCs.

     

    1.  Open the Windows Device Manager interface.  You can find this by typing device into the text box at the bottom of your Windows screen, next to the button in the bottom corner where you shut down the PC.

     

    2.  Insert your RealSense camera if it is not already inserted and expand open the Cameras category of the Device Manager.  There should be two RealSense drivers listed there, Depth and RGB, for the particular RealSense camera models that are currently attached.

     

     

    3.  Right-click on the Depth driver and select the Uninstall device menu option.

     

     

    4.  The next step is vital to the success of the procedure.  A pop-up panel will request confirmation that you wish to uninstall the driver.  There is also a small tick-box on the pop-up panel with the message "Delete the driver software for this device" beside it.  This box must be ticked by left-clicking on it to place a tick in the box, otherwise the issue with the missing infrared streams will not be corrected.

     

    5.  Click the Uninstall confirmation panel on the pop-up panel to confirm that you want to uninstall the depth driver.  The depth driver will disappear from the Cameras section of the Device Manager.

     

    6.  Now repeat the above process for the RGB driver by right-clicking on it and selecting Uninstall, and again ticking the box before clicking Uninstall

     

    7.  There should now be no RealSense drivers listed in the Cameras section.  Unplug the camera from the USB port, wait a couple of seconds and plug the camera back in.  The Depth and RGB drivers should now automatically re-install and reappear in the Cameras section.

     

    8. Finally, launch the RealSense Viewer program and check the Stereo Module options.  The Infrared and Infrared 2 streams should now be listed and able to be enabled.

     

    0
    Comment actions Permalink
  • Nicola Ariutti

    Hi MartyG,
    I have a very similar issue with my C++ code: I'm not able to get any infrared stream and also my RealSense viewer doesn't show any infrared stream available.

    I followed your procedure but after connecting the camera back the driver did not install themselves automatically and I had to install them back manually (from this link).

    I then reopened the RealsenseViewer but I still don't see the infrared streams checkboxes available.

    What am I doing wrong?
    Thanks fro your support

    0
    Comment actions Permalink
  • MartyG

    Please repeat the driver uninstall process above, making sure to complete point 4 or the drivers will not uninstall completely and the missing infrared issue will remain.

     

    After the drivers have been removed and the camera has been unplugged, wait at least a couple of seconds before re-inserting it to make sure that the camera has been fully disconnected.

     

    Do not reinstall the UWP driver after removing the Depth and RGB drivers.  The UWP driver is not required to use RealSense cameras with Windows.  It is only needed if using the camera with hardware or software that supports the Universal Windows Platform, such as the Microsoft Hololens headset.

     

    Also check please that permission for the camera to access the camera hardware and permission for applications to access the camera are both set to 'On' in the Windows privacy settings using the instructions at the link below.

    https://github.com/IntelRealSense/librealsense/issues/3381#issuecomment-503424789

    0
    Comment actions Permalink
  • Nicola Ariutti

    Thank you MartyG,
    I've followed the steps.
    I've succesfully completed the uninstallation for the depth driver (clicking on the "checkbox")

    but I dont see the same "checkbox" when it cames to the RGB driver uninstallation

    I continue with the uninstallation and discossione of the camera from the PC.
    When I connect the camera back to the PC (after waitin for, say, 10 secs) I don't see any camera connected to the PC

    I also made sure that the privacy settings were set as shown in the issue you are referring to



    it was for this reason that I had the doubt that, probably, I would have to install some additional drivers.
    What is going wrong?

    0
    Comment actions Permalink
  • MartyG

    If the camera does not automatically re-install the Depth and RGB drivers after they have been removed, please try clicking on the Scan for hardware changes option on the Device Manager window to see whether installation of the drivers then commences.

     

    0
    Comment actions Permalink
  • Nicola Ariutti

    I've eventually find them listed under USB devices

    but the RealsenseViewer is unable to discover them.

    0
    Comment actions Permalink
  • MartyG

    The drivers should not be under that section.  It indicates a problem if they are.  Please uninstall those two drivers from that location and then repeat the unplug, wait, replug to see if they correctly install to the Cameras section of the Device Manager.

    0
    Comment actions Permalink
  • Nicola Ariutti

    Thank you so much MartyG,
    removing these drivers and connecting back the camera to the PC, I was eventually able to see them in "the correct position" inside the device tree.
    Now the RealsenseViewer is showing me also the IR streams.
    And I'm able to use the infrared stream inside my code!
    Thank you so mush for your patience and support

    0
    Comment actions Permalink
  • MartyG

    You are very welcome, Nicola Ariutti - it's excellent to hear that your problem was resolved.  Thanks very much for the update   :)

    0
    Comment actions Permalink

Please sign in to leave a comment.